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1 Sensitivity

Model System Noise Figure

RF receivers amplify signals and translate them to lower frequencies. The
receiver itself introduces noise that degrades the received signal. The
signal-to-noise ratio (SNR) at the receiver output ultimately determines the
usability of the receiver.
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The preceding figure illustrates the effect of the receiver on the signal. The
receiver amplifies a low-power RF signal at the carrier f,, with a high SNR
and downconverts the signal to f;; The noise figure (NF) of the system
determines the difference between the SNR at the output and the SNR at
the input:

SNR,,; = SNR,, — NF,

sys

where the difference is calculated in decibels. Excessive noise figure in
the system causes the noise to overwhelm the signal, making the signal
unrecoverable.

Create a Low-IF Receiver Model
The model

ex_simrf_snr
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simulates a simplified IF receiver architecture. A Sinusoid block and a Noise
block model a two-tone input centered at f, and low-level thermal noise. The
RF system amplifies the signal and mixes it with the local oscillator f; , down
to an intermediate frequency f;. A voltage sensor recovers the signal at the IF.
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The amplifier contributes 40 dB of gain and a 15-dB noise figure, and the
mixer contributes 0 dB of gain and a 20-dB noise figure, which are values
characteristic of a relatively noisy, high-gain receiver. The two-tone input has
a specified level of .1 pV. A 1-V level in the local oscillator ensures consistency
with the formulation of the conversion gain of the mixer.

To run the model:

1 Open the model by clicking the link or by typing the model name at the
Command Window prompt.

2 Select Simulation > Start.

Models that contain SImRF™ Amplifier and Mixer blocks generate files at
update time. Before you can successfully update and run models with these
blocks, you have to set up a compiler by running mex -setup.
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By default, SImRF software generates files in the current MATLAB® folder.
However, you can change the output location for these files by specifying a
cache folder in the Simulink® Preferences dialog box. To specify a cache folder:

1 Open the Simulink Preferences dialog box (File > Preferences).

2 Specify a location for the Simulink cache folder parameter.

For more information about the Simulink interface, see Simulink Preferences
Window.

Set Up the SimRF Environment
The model simulates according to the following settings:

¢ In the SimRF Parameters Block Parameters dialog box, the Carrier
frequencies parameter specifies the carriers of the SImRF environment:

= frm the carrier of the desired signal, equal to 2 GHz.

= f.0 the frequency of the LO in the first mixing stage, equal to
1.9999 GHz.

= fm the intermediate frequency, equal to f; — f;,, or 100 kHz.
This example uses the variable car_env, defined in the initialization
function, to specify the carriers.

¢ In the Solver Configuration Block Parameters dialog box, the Use local
solver box is selected. This setting causes the SimRF environment to
simulate with a local solver with the following settings:

= The Solver type is set to Trapezoidal rule.

= The Sample time parameter is set to 1/64.

Since the model uses a local solver, the global solver settings do not affect
the simulation within the SimRF environment. For more information on
global and local solvers, see Choosing Simulink and Simscape™ Solvers.

View Simulation Output

The model uses subsystems with a MATLAB Coder™ implementation of a
fast Fourier transform (FFT) to generate two plots. The FFT uses 64 bins,
so for a sampling frequency of 64 Hz, the bandwidth of each bin is 1 Hz.
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Subsequently, the power levels shown in the figures also represent the power
spectral density (PSD) of the signals in dBm/Hz.

¢ The Input Display plot shows the power spectrum of the signal and noise
at the input of the receiver.

ex_simrf_snr/Input Display/fft_2 E@
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The measured power of each tone is consistent with the expected power
level of a 0.1-uV two-tone envelope:

V2
Pin :1010g10 ﬁ +30

2
1107
2 2

= 1010g10 2.50 +30=-142 dBm

A factor of 1/2 is due to voltage division across source and load resistors,
and another factor of 1/2 is due to envelope scaling. See the demo Two-Tone
Envelope Analysis Using Real Signals for more discussion on scaling
envelope signals for power calculation.
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The measured noise floor at -177 dBm/Hz is reduced by 3 dB from the
specified -174 dBm/Hz noise floor. The difference is due to power transfer
from the source to the input of the amplifier. The amplifier also models a
thermal noise floor, so although this decrease 1s unrealistic, it does not
affect accuracy at the output stage.

® The Output Display plot shows the power spectrum of the signal and noise
at the output of the receiver.
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The measured PSD of -102 dBm/Hz for each tone is consistent with the
40-dB combined gain of the amplifier and mixer. The noise PSD in the
figure is shown to be approximately 50 dB higher at the output, due to the
gain and noise figure of the system.

If you have DSP System Toolbox™ software installed, you can replace the
MATLAB Coder subsystems with Vector Scope or Spectrum Scope blocks.

Simulate a Thermal Noise Floor

Thermal noise power can be modeled according to the equation

P

noise

= 4kgTR Af

where:
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® kyis Boltzmann’s constant, equal to 1.38065 x 1023 J/K.
e Tis the noise temperature, specified as 293.15 K in this example.

® R_is the noise source impedance, specified as 50 Q in this example to agree
with the resistance value of the Resistor block labeled R1.

® Afis the noise bandwidth.
To model the noise floor on the RF signal at the resistor, the model uses a
combination of settings in two different blocks.
¢ In the Noise block dialog box:
= The Noise Power Spectral Density (Watts/Hz) parameter is
! Af =4kgTR, .

= The Carrier frequencies parameter, set to carriers.RF, places noise
on the RF carrier only.

calculated as P,

¢ In the SimRF Parameters block dialog box:

= The Simulate Noise box is selected. When this box is cleared, the
model simulates without noise.

= The Noise bandwidth type parameter is set to Absolute bandwidth.

= The Noise bandwidth is 1/sample_time, where sample_time is the
discrete sample time used by the local solver. This setting matches the
Sample time parameter in the Solver Configuration dialog box. This
value specifies Af in the preceding expressions.

The Temperature parameter of the SimRF Parameters block only applies

the specified thermal noise to Amplifier and Mixer blocks.

Computing System Noise Figure
To model RF noise from component noise figures:

1 Select Simulate noise in the SimRF Parameters block dialog box, if it is
not already selected.

2 Specify a value for the Noise figure (dB) parameter of an Amplifier and
Mixer blocks.
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The noise figures are not strictly additive. The amplifier contributes more
noise to the system than the mixer because it appears first in the cascade.
To calculate the total noise figure of the RF system with n stages, use the
Friis equation:

-1 F-1 F
Fsys:F1+F2 LB, n
Gy GGy G1Gsy...G,_4
where F, and G, are the noise factor and gain of the ith stage, and
NF; = 10log, ,(F)).

In this example, the noise figure of the amplifier is 10 dB, and the noise figure
of the mixer is 15 dB, so the noise figure of the system is:

1015/10 _¢

101 1010710
0810 [ 10000

] =10.0dB

The Friis equation shows that although the mixer has a higher noise figure,
the amplifier contributes more noise to the system.

For more information on RF system noise figure, see the demo Impact of RF
Receiver on Communcations System Performance.
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Designing a Receiver with an ADC

Most RF receivers in modern communications or radar systems feed signals
to an analog-to-digital converter (ADC). Due to their finite resolution, ADCs
introduce quantization error into the system. The resolution of the ADC is
determined by the number of bits and the full-scale (FS) range of the ADC.

FU“'SE&“'IE‘ p(}w?r :II- ..........................................

Output signal powerT DR gy
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Qutput nolse power e
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The preceding figure illustrates an RF signal that falls within the dynamic
range (DR) of an ADC. The input signal and noise at the carrier f,, has high
signal-to-noise ratio (SNR). The received signal at f,; has reduced SNR due
to system noise figure. However, if the quantization error is near or above
the receiver noise, system performance degrades.

To ensure that the ADC contributes no more than 0.1 dB of noise to the signal
at f the quantization noise floor must be 16 dB lower than the receiver
noise. This condition can be met by:

¢ Reducing the full-scale (FS) range or increasing the resolution of the ADC,
which lowers the quantization noise floor.

¢ Increasing the gain of the RF receiver, which raises the receiver noise floor.

Overcome Quantization Error of an ADC
The model
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ex_simrf_adc

simulates a low-IF receiver with an ADC. This model is based on the model
ex_simrf_snr described in the section “Create a Low-IF Receiver Model” on
page 1-2. At the output of the RF system, the ADC subsystem models an ADC
with an FS range of sqrt(100e-3) V and a resolution of 16 bits.
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The power a voltage signal at the full-scale range of the ADC is

10log; V100~ +30 = 0 dBm

To run the model:

1 Open the model by clicking the link or by typing the model name at the
Command Window prompt.

2 Select Simulation > Start.

Models that contain SimRF Amplifier and Mixer blocks generate files at
update time. Before you can successfully update and run models with these
blocks, you have to set up a compiler by running mex -setup.
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By default, SImRF software generates files in the current MATLAB folder.
However, you can change the output location for these files by specifying a
cache folder in the Simulink Preferences dialog box. To specify a cache folder:

1 Open the Simulink Preferences dialog box (File > Preferences).

2 Specify a location for the Simulink cache folder parameter.

For more information about the Simulink interface, see Simulink Preferences
Window.

View Simulation Output

The model uses subsystems with a MATLAB Coder implementation of a
fast Fourier transform (FFT) to generate two plots. The FFT uses 64 bins,
so for a sampling frequency of 64 Hz, the bandwidth of each bin is 1 Hz.
Subsequently, the power levels shown in the figures also represent the power
spectral density (PSD) of the signals in dBm/Hz.

¢ The Input Display plot shows the power spectrum of the two-tone signal
and noise at the input of the receiver-ADC system.

ex_simif_adc/Input Display/fft 2 [E=R[E=E =5
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The measured power of each tone of -142 dBm is consistent with the
expected power level of a .1-1V signal. The power level of the noise is
consistent with a -174 dBm/Hz noise floor.

® The Output Display plot shows power spectrum of the output signal.
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The quantization error exceeds the receiver noise.

If you have DSP System Toolbox software installed, you can replace the
MATLAB Coder subsystems with Vector Scope or Spectrum Scope blocks.

Measuring the Quantization Noise Floor

To calculate the quantization noise floor (QNF) of the ADC, subtract the
dynamic range from the full-scale power, which is 0 dBm. To calculate the
dynamic range PSD for the ADC, use the equation:

DRype = 6.02- Ny, +10logyo (Af)+1.76 =116.1 dBm/Hz

where

® Ny

¢ Afis the bandwidth of the FFT, which is 64 in this example. Oversampling
in an ADC yields lower quantization noise.

1s the resolution. The ADC in this example uses 16 bits.
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® The value 1.76 1s a correction factor for a pure sinusoidal input.

Therefore, the quantization noise floor is -116 dBm/Hz, in agreement with
the measured output levels.

Improving Receiver-ADC Performance

Increasing the gain in the mixer raises the receiver noise without increasing
the noise figure. Calculate the mixer gain required to achieve a 16-dB margin
between the quantization noise floor and the receiver noise:

Gpnixer = (@NFype +16) (174 + Gy + NFy,)

=(-116.1+16) - (-174 +40+10.0)
=-100.1+124.0
=23.9dB

To simulate a receiver that clears the quantization noise floor:

1 Set the Available power gain parameter of the mixer to 23.9.

2 Select Simulation > Start.

ex_simif_adc/Output Display/fft 2 [E=R[E=E =5
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The figure shows that the receiver noise is 16 dB above the quantization
noise floor.
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e “Carrier to Interference Performance of a Weaver Receiver” on page 2-2

® “Modeling LO Phase Noise” on page 2-9



2 Interference

Carrier to Interference Performance of a Weaver Receiver

A classic superhetorodyne architecture filters images prior to frequency
conversion. In contrast, image-reject receivers remove the images at the
output without filtering but are sensitive to phase offsets.
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The preceding figure illustrates two input signals at the carriers f;, and

fny that both differ from the LO frequency, f;;, by an amount f,;. Mixing
translates both input signals down to f;,. Perfect image rejection in the final
stage of the receiver removes the image signal from the output entirely.

Create a Model with RF Interference
The model

ex_simrf_ir

simulates image rejection in a Weaver architecture. The receiver
downconverts the signals at fp and f;;, to fz; and f;, in two sequential stages.

2-2
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To run the model:

1 Open the model by clicking the link or by typing the model name at the
Command Window prompt.

2 Select Simulation > Start.

Models that contain SimRF Amplifier and Mixer blocks generate files at
update time. Before you can successfully update and run models with these
blocks, you have to set up a compiler by running mex -setup.

By default, SImRF software generates files in the current MATLAB folder.
However, you can change the output location for these files by specifying a

cache folder in the Simulink Preferences dialog box. To specify a cache folder:

1 Open the Simulink Preferences dialog box (File > Preferences).

2 Specify a location for the Simulink cache folder parameter.

2-3
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For more information about the Simulink interface, see Simulink Preferences
Window.

Set Up the SimRF Environment
The model runs according to the following settings:

¢ In the SimRF Parameters Block Parameters dialog box, the Carrier

frequencies parameter specifies the carriers of the SImRF environment:

= frp the RF carrier.

f the image carrier.
= f.o1> the frequency of the LO in the first mixing stage.
= fLo09 the frequency of the LO in the second mixing stage.

fir> the intermediate frequency of the signal after the first mixing stage,
equal to f; ,, — frp and f1, — fro1-

fim»> the intermediate frequency of the signal after the second mixing
stage, equal to f; o, — f1-

In the Solver Configuration Block Parameters dialog box, the Use local
solver box is selected. This setting causes the SimRF environment to
simulate with a local solver with the following settings:

= Solver type is Trapezoidal rule.

= Sample time is below the Nyquist frequency of the modulation.

Since the model uses a local solver, the global solver settings do not affect
the simulation within the SimRF environment. For more information on
global and local solvers, see Choosing Simulink and Simscape Solvers.

View Simulation Output

The model uses subsystems with a MATLAB Coder implementation of a fast
Fourier transform (FFT) to generate four plots.

¢ The RF Display plot shows the power spectrum of the signal recovered

from the carrier f,p, specified as carriers.RF in the Carrier frequencies
parameter of the preceding SimRF Outport block.
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The modulation of the RF carrier is a constant envelope generated by
a Continuous Wave block which generates a single peak centered at the
carrier.

The Image Display plot shows the power spectrum of the image. The signal
is recovered from the carrier f;,,, specified as carriers.IMin the Carrier
frequencies parameter of the preceding SimRF Outport block.
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ex_simrf_ir/Image Display/fft_2 E@
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The Sinusoid source generates a two-tone signal centered at f;;,.

¢ The IF1 Display plot shows a power spectrum centered at the first
intermediate frequency, measured between the first and second stages.
The sensor outputs the modulation from the carrier f;;;, specified as
carriers.IF2 in the Carrier frequencies parameter of the preceding
SimRF Outport block.
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Both the RF and image appear on the carrier. The power level of the image

40 dB higher than the RF.

The Output Display plot shows the effects of the RF system. The sensor
outputs the modulation from the carrier f;,, specified as carriers.IF1
in the Carrier frequencies parameter of the preceding SimRF Outport

block.
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As expected, the system removes the image and amplifies the RF by 6 dB.

If you have DSP System Toolbox software installed, you can replace the
MATLAB Coder subsystems with Vector Scope or Spectrum Scope blocks.

Modeling RF and Blocker Sources

To model more robust input signals, you can use a SimRF Inport block

to specify a circuit envelope generated using blocks from other Simulink
libraries. For example, the demo Impact of RF Receiver on Communications
System Performance uses Communications System Toolbox™ blocks to model
a QPSK-modulated waveform of random bits with SimRF Inport that brings
the signal into the SimRF environment.

Simulating LO Phase Offset

The phase shifters have specified Phase shift parameters of 90. Deviation
from this value results in a phase offset and causes imperfect image rejection.
The demo Simulating Image Rejection Ratio Measurements analyzes the IRR
of the Weaver and Hartley architectures several times, calculating the image
rejection ratio (IRR) for several different phase offsets.



Modeling LO Phase Noise

Modeling LO Phase Noise

A mixer transfers local oscillator (LO) phase noise directly to its output.

1=
=
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The preceding figure shows the transfer of phase noise from f; ,, to fz.

Create a Model with Phase Noise
The model

ex_simrf_phase_noise

introduces phase noise into the model from the section “Create a Model with
RF Interference” on page 2-2. The first mixing stage downconverts the RF
and image to f
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View Simulation Output

The model uses subsystems with a MATLAB Coder implementation of a fast
Fourier transform (FFT) to generate four plots.

¢ The IF1 Display plot shows a power spectrum centered at the first
intermediate frequency, measured between the first and second stages.
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The figure shows that the LLO phase noise has been transferred to the
image. The RF signal on the carrier f;;, is not visible in the figure because
its power level is below the phase noise power of the downconverted image
signal. The two visible peaks are at the same power as the IF shown in the
previous section, “Create a Model with RF Interference” on page 2-2.

The Output Display plot shows the downconverted RF with the images
removed.
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ex_simrf_phase_noise/Output Display/fft_2 E@

The LO phase noise has been transferred to the receiver output. The peak
signal power is the same as in the previous section, “Create a Model with

RF Interference” on page 2-2.

If you have DSP System Toolbox software installed, you can replace the
MATLAB Coder subsystems with Vector Scope or Spectrum Scope blocks.

Shaping the LO Noise Skirt

To simulate phase noise, the model phase modulates pink noise generated in

the LO with Phase Noise subsystem:

W ex_simif_phase_noise/LO1 with Phase Noise =N e
File Edit View Simulation Format Tools Help
DeE& =] T b= [i

Kiu sL RFp—m(T >

Conn1

>

Random Gain Disgete Filter  Phase

Number Medulate SimRF
Inport
Ready [100% VariableStepDiscrete

The subsystem contains the following blocks:
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¢ A Random Number block outputs a Gaussian random number at discrete
time steps to generate white noise.

® A Gain block scales the signal by a factor of

27 f1,0, 1071
where f, ,, is the LO frequency and P, is the relative noise power density
in dBc/Hz.

¢ A Discrete Filter block filters the uniform white noise to generate 1/f noise.

® A Magnitude-Angle to Complex block phase modulates an input signal ¢.
The output is of the form exp(j@).

* A SimRF Inport block models a controlled voltage source in the SimRF
environment, modulating the carrier f; , with the input signal exp(j¢). The
circuit-envelope equivalent signal is exp[j(2zf,,t + @(1))].

If you have Communications System Toolbox software installed, use the
Phase Noise block to add phase noise to a given input signal.

2-13



2 Interference

2-14



Intermodulation Distortion




3 Intermodulation Distortion

3-2

Modeling a Direct Conversion Receiver

In this section...

“Create a Direct Conversion Receiver Model” on page 3-2

“Modeling IMD in System-Level Components” on page 3-6

“Examining DC Impairments” on page 3-7

Direct-conversion receivers are sensitive to second-order intermodulation
products because they transfer the RF signal directly to baseband.

Create a Direct Conversion Receiver Model
The model

ex_simrf_dc

models a direct-conversion receiver within the SimRF environment. The RF
system consists of a low-noise amplification (LNA) stage, a direct-conversion
stage, and a final amplification stage. The receiver specifications are similar
to the specifications used in the Design and Simulation of a Direct Conversion
Receiver demo, which elaborates on the impairments shown in this example.

W exsimid_dc
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To run the model:

1 Open the model by clicking the link or by typing the model name at the
Command Window prompt.

2 Select Simulation > Start.

Models that contain SimRF Amplifier and Mixer blocks generate files at
update time. Before you can successfully update and run models with these
blocks, you have to set up a compiler by running mex -setup.

By default, SimRF software generates files in the current MATLAB folder.
However, you can change the output location for these files by specifying a
cache folder in the Simulink Preferences dialog box. To specify a cache folder:

1 Open the Simulink Preferences dialog box (File > Preferences).

2 Specify a location for the Simulink cache folder parameter.

For more information about the Simulink interface, see Simulink Preferences
Window.

Set Up the SimRF Environment
The model runs according to the following environment settings:

¢ In the SimRF Parameters Block Parameters dialog box, the Carrier
frequencies parameter specifies the carriers in the SImRF environment:
= frr=f1o the carrier of the RF and the local oscillator.
= fpp, the blocker carrier

The SimRF environment always simulates the 0 Hz carrier, regardless of
whether the SimRF Parameters block specifies it.

® In the Solver Configuration Block Parameters dialog box, the Use local
solver box is selected. This setting causes the SImRF environment to
simulate with a local solver with the following settings:

= Solver type is Trapezoidal rule.
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= Sample time is sample_time, defined as 1.25e-4 in the model
Initialization function.

Since the model uses a local solver, the global solver settings do not affect

the simulation within the SimRF environment. For more information on

global and local solvers, see Choosing Simulink and Simscape Solvers.

View Simulation Output

The model uses subsystems with a MATLAB Coder implementation of a fast
Fourier transform (FFT) to generate four plots:

¢ The RF Display plot shows the power level of the RF signal.

ex_simf_dc/RF Display/fft_2 = e e
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The power level of the RF is about 100 dBm.

® The Blocker Display plot shows the power spectrum centered at the carrier

far--

3-4



Modeling a Direct Conversion Receiver

ex_simrf_dc/Blocker Display/fft_2
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The power level of the blocker is about 90 dB higher than the signal power

of the RF..

® The In-Phase Output plot shows the power spectrum of the in-phase signal

at baseband.

ex_simif_de/In-Phase Output/fft_2
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In the figure, DC power is a direct result of the blocker and the IP2 in

the mixers.
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® The Quadrature Output plot shows the power spectrum of the quadrature
signal at baseband.

ex_simrf_dc/Quadrature Output/fft_2 E@
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The quadrature output only contains noise because the input signal and
blocker have no quadrature components.

If you have DSP System Toolbox software installed, you can replace the
MATLAB Coder subsystems with Vector Scope or Spectrum Scope blocks.

Modeling IMD in System-Level Components

The IP2 and IP3 parameters specify the second- and third-order intercept
points of Amplifier and Mixer blocks:

® The amplifiers have infinite IP2 and IP3, so the amplifiers are linear.

e IP2 of the mixer is -10 dB
Amplifier and Mixer components have specified gains and noise figures:

® The gain and noise figure in the LNA stage are 25 dB and 6 dB, respectively.

® The gain and noise figure in the mixing stage are 10 dB and 10 dB.
The Input impedance (ohms) parameters of the two mixers are both
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100, which sum in parallel to a resistance of 50 Q to match the output
impedance of the LNA.

¢ The gain and noise figure in the final amplification stage are 20 dB and
15 dB, respectively.

To calculate RF system noise figure, use the Friis equation:

F,-1 F,-1 F

Fyo=R+2—-+23 -4 4 n
Gy GGy G1Gsy...G,_4

where F; and G, are the noise factor and gain of the ith stage. For more

information on RF system noise figure, see the demo Impact of RF Receiver

on Communcations System Performance.

Examining DC Impairments

In addition to intermodulation distortion from IP2, direct-conversion receivers

are subject to additional DC impairments. For example, coupling between
mixer input and local oscillator (LO) ports causes self-mixing of the LO.
For more information, see the demo Executable Specification of a Direct
Conversion Receiver.
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